Deepblu FAQ | The app doesn’t work on my Android phone. Why?
21682
post-template-default,single,single-post,postid-21682,single-format-standard,ajax_fade,page_not_loaded,,select-theme-ver-3.7,wpb-js-composer js-comp-ver-5.0.1,vc_responsive

The app doesn’t work on my Android phone. Why?

The Deepblu app only works on Android devices running Android version 4.4 (Kitkat) and up. If the app is still not working, please email apps@deepblu.com and we will investigate the problem.