Deepblu FAQ | What Apple devices is the Deepblu app compatible with?
21684
post-template-default,single,single-post,postid-21684,single-format-standard,ajax_fade,page_not_loaded,,select-theme-ver-3.7,wpb-js-composer js-comp-ver-5.0.1,vc_responsive

What Apple devices is the Deepblu app compatible with?

Currently, the app is compatible with iPhone 5 and above. All Apple devices must be running iOS 8 or higher. While the Deepblu app technically works on iPad 3 and above, the user experience is not optimized for tablets and you may encounter glitches on the iPad. We are working on a better experience on tablet computers.